First unread post problem

Suggestions & Help using the Volkswagen T-Roc Forum
Post Reply
Impala
Posts: 1619
Joined: Sat May 12, 2018 3:03 pm

First unread post problem

Post by Impala » Sat Jul 04, 2020 2:07 pm

I'm certain this is not my imagination, but there seems to be a problem with the 'First unread post' link.
The issue may be intermittent, but I've recently noticed that the link takes me to the last page and skips over unread posts on earlier page(s).

Anyone else experiencing this ?

I'm using Firefox browser on a laptop running Windows 10.
1.5 TSI DSG R-Line Indium Grey, rear view camera, park assist.
Ordered 22/06/18
Built w/c 25/03/19 :(
With dealer 13/05/19 :P
Collected 20/05/19 :D

Tricky2
Posts: 48
Joined: Sun Mar 22, 2020 2:37 pm

Re: First unread post problem

Post by Tricky2 » Sat Jul 04, 2020 10:27 pm

I use the "what's new" button.

User avatar
twist
Posts: 1100
Joined: Sun Mar 17, 2019 7:38 pm

Re: First unread post problem

Post by twist » Sat Jul 04, 2020 10:55 pm

Same as Tricky, I find “new posts” to be more accurately “stuff I have not seen yet.”
1.5 DSG R-line in Indium Grey
Keyless, park assist, rear view cam, driver assist pack plus, lumbar support
Ordered: 11/12/19 / Collected 20/03/20

User avatar
vernerbongo2
Posts: 1028
Joined: Mon Dec 24, 2018 1:18 am

Re: First unread post problem

Post by vernerbongo2 » Sat Jul 04, 2020 11:00 pm

I use the active topics tab :P
Manual 1.5 petrol R-line revenna blue with black roof/wing mirrors, mud flaps, towbar.
Registered 24/9/18 bought 10/12/18 (pre-reg with 25 miles) :P

Impala
Posts: 1619
Joined: Sat May 12, 2018 3:03 pm

Re: First unread post problem

Post by Impala » Mon Jul 06, 2020 7:20 pm

Tricky2, Twist, Vernerbongo2 ... you have all misunderstood my post and the reported problem.

What's New/Active Topics and Recent Topics merely identify the topics with new posts, and I use those too.

But what I'm referring to is when you open/view a topic. At the top of each page, there is a link to jump to the 'First unread post' in that topic, alongside a count of the number of posts and links to jump to specific pages ... see the screen shot.

First unread post.png

With a very active topic getting lots of posts or if you are catching up after a few days away, the first unread post is often not on the last page, so being able to use the 'First unread post' link was a quick and convenient way to pickup from where you last read, with sometimes several pages of unread posts.

The problem I've noticed over the past few days/weeks is that the link is now tending to jump to the last page and misses unread posts in earlier pages.

Please try it, but it seems to be working for me tonight.
1.5 TSI DSG R-Line Indium Grey, rear view camera, park assist.
Ordered 22/06/18
Built w/c 25/03/19 :(
With dealer 13/05/19 :P
Collected 20/05/19 :D

User avatar
twist
Posts: 1100
Joined: Sun Mar 17, 2019 7:38 pm

Re: First unread post problem

Post by twist » Mon Jul 06, 2020 8:12 pm

Impala wrote:
Mon Jul 06, 2020 7:20 pm
Tricky2, Twist, Vernerbongo2 ... you have all misunderstood my post and the reported problem.

What's New/Active Topics and Recent Topics merely identify the topics with new posts, and I use those too.

But what I'm referring to is when you open/view a topic. At the top of each page, there is a link to jump to the 'First unread post' in that topic, alongside a count of the number of posts and links to jump to specific pages ... see the screen shot.

First unread post.png

With a very active topic getting lots of posts or if you are catching up after a few days away, the first unread post is often not on the last page, so being able to use the 'First unread post' link was a quick and convenient way to pickup from where you last read, with sometimes several pages of unread posts.

The problem I've noticed over the past few days/weeks is that the link is now tending to jump to the last page and misses unread posts in earlier pages.

Please try it, but it seems to be working for me tonight.
I honestly never even noticed that link 🤦‍♂️ I wish I had known about it though, as I’d have perhaps not missed some of the posts I did!

I’ll give it a shot and see. But I have noticed (potentially related) is that the link that takes you to the latest post often doesn’t actually go to it (on mobile anyway), it instead scrolls way past it to the reply form. It could be an issue with the back end not knowing which page the post it’s looking for is on or an issue with where anchors are placed.

Maybe Rob could check if there are any updates to the plugins for the site? Might resolve some of these quirks.
1.5 DSG R-line in Indium Grey
Keyless, park assist, rear view cam, driver assist pack plus, lumbar support
Ordered: 11/12/19 / Collected 20/03/20

User avatar
vernerbongo2
Posts: 1028
Joined: Mon Dec 24, 2018 1:18 am

Re: First unread post problem

Post by vernerbongo2 » Mon Jul 06, 2020 9:26 pm

Right, I didn't actually realise that's what the "unread posts" link did.
I literally thought it was posts no one had read :lol:
If I've picked you up right, theoretically if I click on the post topic on the unread page it should skip to where I left off previously?

Screenshot_20200706_221633.jpg

The links only open for me on the first page of every topic but that's possibly because I cleared my cookies and history?
Manual 1.5 petrol R-line revenna blue with black roof/wing mirrors, mud flaps, towbar.
Registered 24/9/18 bought 10/12/18 (pre-reg with 25 miles) :P

Impala
Posts: 1619
Joined: Sat May 12, 2018 3:03 pm

Re: First unread post problem

Post by Impala » Tue Jul 07, 2020 3:59 pm

Sorry Vernerbongo, that is not the same thing.

I believe you have clicked on 'Unread posts' in the 'QUICK LINKS' drop-down menu and. That is basically just the same as the 'Recent topics' section on the Home page and both of these display a list of Topics with unread posts (most recent first). As you have stated, clicking a topic title in thoses lists takes you to the very first post of the topic. The web page layout is simplified for mobile phone usage, but when using a PC or laptop there is a small arrow to the right of the name of the person who made the last post and clicking this takes you to the very LAST post in the topic. I'm guessing that is replicated on a mobile phone and shown in your screen shot by clicking the link 'Last post by ....' on the line below the topic title.

Lots of confusion here as there are several ways to do the same thing, and there are obviously variations when using a phone or PC/Laptop.

However, none of the above is the feature I'm referring to and as far as I can determine there is only one way to jump to the first unread post. I've captured some additional screen shots to show the different results for 'First', 'Last' and 'First unread', but these are all on a laptop and the 'First unread post' link may never be shown on a phone as I've never tried it.

You jump to the 'First' post by clicking the Topic title. If there are unread posts in the topic, a 'First unread post' link is added beside the list of pages, as circled below. When there are no unread posts, the link is not shown.

First post.png



You jump to the 'Last' post as I described above -

Last post.png



Clicking the 'First unread post' in this example, jumps to the post immediately before the last post shown above, but if there were many unread posts, it would start at the first one, which could even be one or more pages before the last post page.

First unread post.png



It would seem that neither you nor Twist see the 'First unread post' link, so this discussion has somewhat diverged from my original question about whether or not the link is working properly. It's still working for me today, so maybe the problem was some sort of glitch on the web site.

Probably not worth wasting any more time on this.
1.5 TSI DSG R-Line Indium Grey, rear view camera, park assist.
Ordered 22/06/18
Built w/c 25/03/19 :(
With dealer 13/05/19 :P
Collected 20/05/19 :D

Bellasdad
Posts: 98
Joined: Sun Aug 19, 2018 4:18 pm

Re: First unread post problem

Post by Bellasdad » Tue Jul 07, 2020 6:19 pm

It sometimes skips a couple of posts for me, I do tend to scroll up and also check the previous page to make sure I haven't missed anything.
It's become a bit of a habit for me as this problem has been happening for quite some time.
T-Roc R Line 1.5 manual. White silver with black roof.

Impala
Posts: 1619
Joined: Sat May 12, 2018 3:03 pm

Re: First unread post problem

Post by Impala » Tue Jul 07, 2020 6:54 pm

Bellasdad wrote:
Tue Jul 07, 2020 6:19 pm
It sometimes skips a couple of posts for me, I do tend to scroll up and also check the previous page to make sure I haven't missed anything.
It's become a bit of a habit for me as this problem has been happening for quite some time.
Thanks ... now I know I haven't been imagining it.

I haven't identified any pattern, but it doesn't always do it.
1.5 TSI DSG R-Line Indium Grey, rear view camera, park assist.
Ordered 22/06/18
Built w/c 25/03/19 :(
With dealer 13/05/19 :P
Collected 20/05/19 :D

Post Reply