Blank Sat Nav

All Volkswagen T-Roc related discussions
Post Reply
Hawkeye
Posts: 723
Joined: Fri Oct 12, 2018 2:36 pm
Has thanked: 46 times
Been thanked: 243 times

Blank Sat Nav

Post by Hawkeye » Sat Nov 30, 2019 12:42 am

Well the Sat Nav finally spat its toys out of the pram tonight.

To set the scene - set up Sat Nav to navigate to my sons new house and also connected my iPhone (on iOS 13) using ApplePlay. Done this plenty of times before, no problem.

First off after 20 mins, in comes a WhatsApp message and the Sat-Nav and ApplePlay decide to both flash, first one then the other. Pressed the Nav button and it stopped it.
About 10 mins later, just driving along and suddenly the Sat-Nav map went black (as though I’d transferred it onto the dash) but the remainder of the screen still showed speed limit, etc. However it froze at this point as well. Tried voice control to stop sat nav. Wouldn’t, just kept saying wait. Swapped to Radio then back again. No difference. Switched system off completely and back on. No difference.
Pulled over, switched car off, took ignition key out, waited a few minutes and restarted. No difference.
Gave up, swapped to Google Maps under ApplePlay to complete my journey.
Got to sons, left car parked up for about 3 hours.
Get back in. Hurrah Map is showing in the Infotainment. Tried to enter navigation to home. Every time I put something in (wherever it was) it said calculating route, followed immediately by “you have arrived”. So still useless then. Back to Google Maps under ApplePkay to navigate home.
Eventually get onto M25, so knew where I was. Hit the Nav button and the map is quite happily showing my position. For the hell of it, selected my home address and pressed start. And it then proceeded to calculate the route and work properly like nothing had happened. So stopped Google Maps and let it run for a while. Worked perfectly for the rest of the way home.

Given my recent “Can’t find NEC Birmingham” Nav experience, I’m started to wonder if:
- my SD CARD has a bad track OR is slightly corrupted (so needs a new card)
- the Infotainment system needs re-setting / needs a software update / needs replacing under warranty
- the aerial on the car needs replacing

Anyone had anything similar happen? When I “lost” the map and the Nav froze initially everything else like radio etc worked, it was only the Nav that threw a hissy fit, but now seems to be working perfectly again (which means that a dealership won’t find an error when they look at it)

Thoughts?
R-Line 2.0TSi DSG 4MOTION
Silver White with Black Roof
Panoramic Sunroof
'Beats' Sound system
Electric Tailgate
Rear View Camera
Park Assist
Driver Assistance Pack Plus

Ordered 20-10-18
Collected 19-03-19

RedRoc
Posts: 140
Joined: Sun Nov 05, 2017 12:09 am
Location: South Yorks. UK
Has thanked: 7 times
Been thanked: 26 times

Re: Blank Sat Nav

Post by RedRoc » Sat Nov 30, 2019 9:20 am

Sounds to me that 'ApplePlay', on the VW side of things, was waiting for a response, or something, after the WhatsApp notification and wouldn't give control back to the cars info system. Might even have been Whatsapp that got 'stuck'. On opening and starting maps on return journey, you may have reset the 'ApplePlay' to ignore waiting for a response.
T-Roc 1.0 SE Flash Red -

Hawkeye
Posts: 723
Joined: Fri Oct 12, 2018 2:36 pm
Has thanked: 46 times
Been thanked: 243 times

Re: Blank Sat Nav

Post by Hawkeye » Sat Nov 30, 2019 10:30 am

RedRoc wrote:
Sat Nov 30, 2019 9:20 am
Sounds to me that 'ApplePlay', on the VW side of things, was waiting for a response, or something, after the WhatsApp notification and wouldn't give control back to the cars info system. Might even have been Whatsapp that got 'stuck'. On opening and starting maps on return journey, you may have reset the 'ApplePlay' to ignore waiting for a response.
Thanks - I did wonder that, but had dismissed it as everything has run ok together to date (but that's not to say last night it did).
Good point @RedRoc and I think you may be right. I think rather than take to a dealers I'll see how it works out over the next few weeks, if it does it again then there is clearly a problem either with the ApplePlay handshake or the unit itself, if not well, then maybe it was just having a hissy fit. The Sat Nav's on my Audi's did that occasionally (joys of modern technology I guess).
R-Line 2.0TSi DSG 4MOTION
Silver White with Black Roof
Panoramic Sunroof
'Beats' Sound system
Electric Tailgate
Rear View Camera
Park Assist
Driver Assistance Pack Plus

Ordered 20-10-18
Collected 19-03-19

Post Reply