Android Auto disconnects...Shud I get a satnav?

All Volkswagen T-Roc related discussions
Post Reply
TheROC
Posts: 65
Joined: Mon May 20, 2019 11:22 am
Has thanked: 4 times
Been thanked: 7 times

Android Auto disconnects...Shud I get a satnav?

Post by TheROC » Tue Dec 03, 2019 10:30 am

Assuming that the android auto would work fine, I didn't opt for the in-built satnav but now facing trouble with it.
Each time i set on a journey, android auto disconnects after few mins.
As a new driver living in a not-so-familiar locality, I rely on satnavs.

Is there a fix available for this issue?
If not, I would like to a separate satnav, ideally with lane guidance and as much assistance that I can possibly have.

I did a bit of research and have shortlisted Garmin Drive Smart for its lane guidance, voice guidance using landmarks (eg. at traffic lights) rather than road number and a good display of information such as speed limit, speed camera, road layout ahead.

I have got some questions:
Which is the better model S version or D version?
Are there other relatively unknown satnav brands that have superior function.
Whats the best and safe screen size - 5.5inch or 6 inch
Can I display/mirror the garmin satnav on the in-board infotainment screen?
I have a 7 year old personal smart phone which may not have some technology for mirroring and my work phone doesnt allow to download apps other than android auto.
Ordered: 21 May 19
Stage 3 : 19 July
Build week : 26 August
Stage 5a (In transit: left factory) : Sat 31 Aug
Stage 6: 13th & 19th Sept
Stage 7: 20th Sept
Deliverd: 10th Oct

TheROC
Posts: 65
Joined: Mon May 20, 2019 11:22 am
Has thanked: 4 times
Been thanked: 7 times

Re: Android Auto disconnects...Shud I get a satnav?

Post by TheROC » Tue Dec 03, 2019 10:42 am

Is there any other alternative to Android Auto that will work on the infotainment ?
Ordered: 21 May 19
Stage 3 : 19 July
Build week : 26 August
Stage 5a (In transit: left factory) : Sat 31 Aug
Stage 6: 13th & 19th Sept
Stage 7: 20th Sept
Deliverd: 10th Oct

ChrisR
Posts: 34
Joined: Fri May 03, 2019 11:00 pm
Has thanked: 7 times
Been thanked: 7 times

Re: Android Auto disconnects...Shud I get a satnav?

Post by ChrisR » Tue Dec 03, 2019 10:59 am

TheROC wrote:
Tue Dec 03, 2019 10:42 am
Is there any other alternative to Android Auto that will work on the infotainment ?
Whatever the Apple version is, but if you're on Android that's no help. I've found that this issue was caused in mine by the socket being a bit grubby / slightly misaligned by the cable shifting and the plug wiggling it slightly. The other change I made was to use a higher quality cable, as apparently all cables are not created equal! The VW USB cable I was given works great, the cable that came with my Samsung doesn't.
SE 1.5 TSI Manual - Ravenna Blue
Received Jul 2019 - Rejected Aug 2019 - Still Rooing Nov 2019

TheROC
Posts: 65
Joined: Mon May 20, 2019 11:22 am
Has thanked: 4 times
Been thanked: 7 times

Re: Android Auto disconnects...Shud I get a satnav?

Post by TheROC » Tue Dec 03, 2019 11:15 am

I have been using the VW cable provided by the dealer
Ordered: 21 May 19
Stage 3 : 19 July
Build week : 26 August
Stage 5a (In transit: left factory) : Sat 31 Aug
Stage 6: 13th & 19th Sept
Stage 7: 20th Sept
Deliverd: 10th Oct

ChrisR
Posts: 34
Joined: Fri May 03, 2019 11:00 pm
Has thanked: 7 times
Been thanked: 7 times

Re: Android Auto disconnects...Shud I get a satnav?

Post by ChrisR » Tue Dec 03, 2019 1:30 pm

Strange, maybe the jack in the vehicle is a bit dodgy or could be the port in the phone. They can get damaged over time as charging cables are yanked out and fumbled in :-/
SE 1.5 TSI Manual - Ravenna Blue
Received Jul 2019 - Rejected Aug 2019 - Still Rooing Nov 2019

Impala
Posts: 1283
Joined: Sat May 12, 2018 3:03 pm
Has thanked: 124 times
Been thanked: 458 times

Re: Android Auto disconnects...Shud I get a satnav?

Post by Impala » Tue Dec 03, 2019 2:24 pm

The first option should be to try another phone if you have a partner or friend willing to oblige for a test. You also need to check the versions of Android and the Android Auto app used on each phone.

It may be that your software needs updating, or you need to invest in a new 'personal' phone that others on the forum can confirm working with Android Auto in their T-Rocs. I think you will find plenty are using their phones for SatNav without problems.
1.5 TSI DSG R-Line Indium Grey, rear view camera, park assist.
Ordered 22/06/18
Built w/c 25/03/19 :(
With dealer 13/05/19 :P
Collected 20/05/19 :D

RP22
Posts: 25
Joined: Fri Jul 12, 2019 11:50 am
Been thanked: 5 times

Re: Android Auto disconnects...Shud I get a satnav?

Post by RP22 » Thu Dec 05, 2019 12:06 pm

Hello TheROC, I have a bit of input here about cables. I too wanted the Android Auto App to work in the T-Roc Infotainment Screen. I also dislike excess cables lying around so I started looking for a retractable USB A to USB C cable. Depends what phone you have whether you have a USB C, micro, mini etc. Eventually I found one made by ReTrak retailing via a firm called Emerge. You will find it if you Google, it was not cheap and despite its description it did not work – just charged the phone and did not allow Android Auto app to work. I was refunded no problem.

I had more or less given up when I stumbled on this https://www.vonmaehlen.com/premium-cabl ... usb-c?c=69 I ordered it from Germany at £16.05 and it is absolutely brilliant. It is beautifully made, works a bit like a yo-yo in that you wrap excess cable around a central core, where it is held. Android Auto works a dream. There are variants e.g. USB to Micro USB, and in different colours. The cable and conectors are good material. It is really good, wonderful quality.

They also do a different product called the Allrondo which does the full Monty, connection-wise, and which also works with Android Auto. Their excellent Customer Service sent me a video of the Allrondo working Android Auto but it was more than I needed and I went for the Premium Cable instead. Brilliant

Post Reply